Native Instruments - Traktor Audio 2 MK2

General Mixxx discussion.... discuss

Moderator: garth

Re: Native Instruments - Traktor Audio 2 MK2

Postby RafaelV » Sat Feb 09, 2019 7:44 pm

Yes, there is 3 controls.
- PCM front. 46<>46.
- PCM back. 46<>46.
- PCM 1. 46.

I can see on the top: PCM [gain dB: -20,01, -20,01], for all three different PCM.
Attachments
Capture du 2019-02-09 21-08-01.png
Capture du 2019-02-09 21-08-01.png (15.72 KiB) Viewed 566 times
RafaelV
 
Posts: 66
Joined: Sat Mar 16, 2013 11:46 am

Re: Native Instruments - Traktor Audio 2 MK2

Postby Be. » Sat Feb 09, 2019 8:31 pm

Have you tried changing those controls in alsamixer?
I heard FLAC and I haven't gone back.
Protect your hearing with earplugs!

Hear my mixes
User avatar
Be.
Mixxx Developer
 
Posts: 2495
Joined: Tue Jan 06, 2015 1:00 am
Location: Chicago, USA

Re: Native Instruments - Traktor Audio 2 MK2

Postby RafaelV » Sat Feb 09, 2019 9:18 pm

Yes,
- PCM front impacts strongly the Master output of the Audio 2 MK2.
- PCM back impacts strongly the Headphone output of Audio 2 MK2.
- PCM 1 do not do nothing.

After re-boot of the laptop, these settings return to 46.
RafaelV
 
Posts: 66
Joined: Sat Mar 16, 2013 11:46 am

Re: Native Instruments - Traktor Audio 2 MK2

Postby Be. » Sun Feb 10, 2019 1:52 am

Interesting. I'm not sure what is happening here. Perhaps on Windows the driver remembers the values those are set to or sets them to the max level when the device is plugged in. Maybe ALSA expects the hardware to remember the values or maybe ALSA resets the values to 46 when it is plugged in. Perhaps you'll have luck asking about this on the alsa-devel email list. Attach the output of "lsusb -v" with your post there.
I heard FLAC and I haven't gone back.
Protect your hearing with earplugs!

Hear my mixes
User avatar
Be.
Mixxx Developer
 
Posts: 2495
Joined: Tue Jan 06, 2015 1:00 am
Location: Chicago, USA

Re: Native Instruments - Traktor Audio 2 MK2

Postby Be. » Sun Feb 10, 2019 1:53 am

Are those levels reset to 46 when you unplug and replug the Traktor Audio 2 Mk2 without rebooting?
I heard FLAC and I haven't gone back.
Protect your hearing with earplugs!

Hear my mixes
User avatar
Be.
Mixxx Developer
 
Posts: 2495
Joined: Tue Jan 06, 2015 1:00 am
Location: Chicago, USA

Re: Native Instruments - Traktor Audio 2 MK2

Postby RafaelV » Sun Feb 10, 2019 5:35 pm

Yes, levels reset to 46 when unplug and replug the Traktor Audio 2 Mk2 without rebooting.

I tried to store the alsamixer settings at 100, with
Code: Select all
sudo alsactl store


It worked and doesn't worked:
- stored settings (100) are present after unplug/replug Traktor Audio 2 Mk2 or reboot of the laptop.
- but sound level output doesn't changed (similar to 46), until I reduce a little bit the alsamixer gain of Master output.
Strange.

I think I will use alasamixer each time before DJing in order to put levels at 100.

Thanks for your help.
RafaelV
 
Posts: 66
Joined: Sat Mar 16, 2013 11:46 am

Re: Native Instruments - Traktor Audio 2 MK2

Postby DanDanDaDJMan » Sat Dec 07, 2019 2:50 pm

This is what I needed to do to automatically set 100% volume on all output channels. Tested on Ubuntu 18.04:

1) Add your user account to the 'audio' group (then relogin for the change to take effect):
usermod -a -G audio your_username

2) sudo vi /etc/udev/rules.d/90-traktor-audio2.rules

3) Add the following line to the file:
ATTRS{idVendor}=="17cc", ATTRS{idProduct}=="1330", GROUP="audio",MODE="0660", RUN+="/usr/bin/amixer -c 1 set PCM playback 100%"

4) sudo /etc/init.d/udev restart

5) Replug the Traktor Audio 2 back into your USB port

To see if this worked, I just ran the following:
$ amixer -c 1
Simple mixer control 'PCM',0
Capabilities: pvolume pswitch
Playback channels: Front Left - Front Right - Rear Left - Rear Right
Limits: Playback 0 - 16384
Mono:
Front Left: Playback 16384 [100%] [0.00dB] [on]
Front Right: Playback 16384 [100%] [0.00dB] [on]
Rear Left: Playback 16384 [100%] [0.00dB] [on]
Rear Right: Playback 16384 [100%] [0.00dB] [on]
Simple mixer control 'PCM',1
Capabilities: pvolume pvolume-joined pswitch pswitch-joined
Playback channels: Mono
Limits: Playback 0 - 32767
Mono: Playback 32767 [100%] [0.00dB] [on]

All channels should show 100% volume. Previously, the "Front" channels were showing 86%.

For some strange reason the ALSA driver identifies the device as a 4-channel surround-sound device. It treats the MAIN line as 'Front' channels, and the Headphone as 'Rear' channels.

HTH!
DanDanDaDJMan
 
Posts: 1
Joined: Sat Dec 07, 2019 2:34 pm

Previous

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 3 guests