[Solved] Mixxx can't find QtSQL drivers

Fixxx your Mixxx

Moderator: garth

[Solved] Mixxx can't find QtSQL drivers

Postby nicodr » Fri Oct 27, 2017 4:59 pm

Hello,

I am trying to use Mixxx on Xubuntu, but when running it, Mixxx is unable to find QtSQL drivers and stop immediately.

I get the following log:
Code: Select all
Debug [Main]: Mixxx "2.0.0-release" "(git 1.12 r5796; built on: Jun  4 2016 @ 03:16:21; flags: asan=0 asmlib=0 autodjcrates=1 buildtime=1 bulk=1 color=0 coreaudio=0 faad=0 ffmpeg=0 hid=1 hss1394=0 ipod=0 localecompare=1 macappstore=0 mad=1 mediafoundation=0 modplug=0 optimize=portable opus=1 perftools=0 perftools_profiler=0 profiling=0 qdebug=1 qt_sqlite_plugin=0 shoutcast=1 test=False vamp=1 verbose=1 vinylcontrol=1 wv=0)" is starting...
Debug [Main]: Library versions:
Debug [Main]: Qt: 4.8.7
Debug [Main]: libshout: 2.3.1
Debug [Main]: RubberBand: 1.8.1
Debug [Main]: SoundTouch: 1.8.0
Debug [Main]: TagLib: 1.9.1
Debug [Main]: ChromaPrint: 1.2.0
Debug [Main]: Vorbis: Xiph.Org libVorbis 1.3.5
Debug [Main]: FLAC: 1.3.1
Debug [Main]: QDesktopServices::storageLocation(HomeLocation): "/home/pmangold"
Debug [Main]: QDesktopServices::storageLocation(DataLocation): "/home/pmangold/.local/share/data//Mixxx"
Debug [Main]: QCoreApplication::applicationDirPath() "/usr/bin"
Warning [Main]: Configuration file is at version "2.0.0" instead of the current 2.0.0-release
Debug [Main]: Loading resources from  "/usr/share/mixxx/"
Debug [Main]: Loading resources from  "/usr/share/mixxx/"
Debug [Main]: ConfigObject: Could not read "/home/pmangold/.mixxx/sandbox.cfg"
Debug [Main]: Loading resources from  "/usr/share/mixxx/"
Debug [Main]: Loading resources from  "/usr/share/mixxx/"
Debug [Main]: Loading translations for locale "fr_FR" from translations folder "/usr/share/mixxx/translations/" : success
Debug [Main]: Loading resources from  "/usr/share/mixxx/"
Debug [Main]: Compressor attack per frame:  0.000408163 decay per frame:  4.08163e-05
Debug [Main]: PortAudio version: 1899 text: PortAudio V19-devel (built Aug 11 2015 07:04:31)
Debug [Main]: JACK client name set
Warning [Main]: ControlDoublePrivate::getControl returning NULL for ( "[Auxiliary1]" , "passthrough" )
Warning [Main]: ControlDoublePrivate::getControl returning NULL for ( "[Auxiliary2]" , "passthrough" )
Warning [Main]: ControlDoublePrivate::getControl returning NULL for ( "[Auxiliary3]" , "passthrough" )
Warning [Main]: ControlDoublePrivate::getControl returning NULL for ( "[Auxiliary4]" , "passthrough" )
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Debug [Main]: WARNING: AudioInput already registered!
Warning [Main]: QSqlDatabase: QSQLITE driver not loaded
Warning [Main]: QSqlDatabase: available drivers:
Debug [Main]: Available QtSQL drivers: ()
Debug [Main]: DB status: "" = false
Debug [Main]: Error loading database: QSqlError(-1, "Driver not loaded", "Driver not loaded")


It says QSQLITE driver is not loaded, which seems to be true as no driver is available. Do you know how to fix this? I can't manage to install some drivers for Qt... Not sure I understood everything here though...

Thank you very much!

Edit:
I finally managed to fix the problem by uninstalling libqt4-sql-sqlite and installing it again...
nicodr
 
Posts: 1
Joined: Fri Oct 27, 2017 4:55 pm

Return to Troubleshooting & FAQ

Who is online

Users browsing this forum: Bing [Bot] and 7 guests