User Tools

Site Tools


eclipse

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
eclipse [2020/01/07 12:30]
hlzhs
eclipse [2020/01/14 17:26] (current)
daschuer [Step-by-Step Setup]
Line 146: Line 146:
     * search for cmake4eclipse and press Install. ​     * search for cmake4eclipse and press Install. ​
     * Follow the install Wizzard and restart Eclipse     * Follow the install Wizzard and restart Eclipse
-  * File -> New -> Project... -> C++ Project ​+  * File -> New -> Project... -> C++ Project ​(!**Not** File -> New -> C/C++ Project) ​
   * Set Project Name to ''​mixxx''​   * Set Project Name to ''​mixxx''​
   * Uncheck "Use default location"​   * Uncheck "Use default location"​
   * Browse to your Mixxx source folder e.g. ''​~/​eclipse-workspace/​mixxx''​.   * Browse to your Mixxx source folder e.g. ''​~/​eclipse-workspace/​mixxx''​.
-  * Project Type: Executable ​-> Empty Project +  * Project Type: CMake driven ​-> Empty Project
-  * Toolchains: Linux GCC (this would be for a Linux host, substitute your OS as applicable).+
   * click Finish ​   * click Finish ​
-  * Right click on the new project in Project Explorer -> Properties -> C/C++ Build -> Tool Chain Editor (if Project Explorer is not visible, go to Window -> Show View -> Project Explorer). 
-  * Curent builder: "CMake Builder (portable)"​ 
   * Right click on the new project in Project Explorer -> Properties -> C/C++ Build   * Right click on the new project in Project Explorer -> Properties -> C/C++ Build
   * Switch to Behavior tab.   * Switch to Behavior tab.
-  * Check "​Enable parallel builds". +  * Check "​Enable parallel builds"​ and select ​"Use optimal jobs"
-  * Right click on the new project in Project Explorer -> Properties -> C/C++ General -> Preprocessor Include ...  +
-  * Switch to Providers tab +
-  * check "​CMAKE_COMPILE_COMMANDS_JSON Parser" and "CMAKE_COMPILE_COMMANDS_JSON Compiler Built-Ins" ​and uncheck others+
  
 Now Mixxx should build within Eclipse with "Build Project"​ (Hammer icon). ​ Now Mixxx should build within Eclipse with "Build Project"​ (Hammer icon). ​
eclipse.txt · Last modified: 2020/01/14 17:26 by daschuer