User Tools

Site Tools


eclipse

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
Next revision Both sides next revision
eclipse [2019/11/17 16:40]
daschuer [Install Eclipse (packages or source)]
eclipse [2019/11/22 16:57]
daschuer
Line 36: Line 36:
 mkdir build/​Debug ​ mkdir build/​Debug ​
 cd build/Debug cd build/Debug
-cmake ../..+cmake -DCMAKE_BUILD_TYPE=Debug -DCMAKE_EXPORT_COMPILE_COMMANDS:​BOOL=ON ​../.. 
 make -j4 # replace 4 with the number of CPU cores that can be utilized make -j4 # replace 4 with the number of CPU cores that can be utilized
 </​code>​ </​code>​
Line 81: Line 81:
  
 For Eclipse 2018-09 For Eclipse 2018-09
 +
 +General:
  
   * Start Eclipse.   * Start Eclipse.
Line 92: Line 94:
   * Expand C/C++ -> Build -> console   * Expand C/C++ -> Build -> console
   * Limit console output = 10000   * Limit console output = 10000
-  * ---+  * Verify Project Explorer is visible. If not go to Window ​-> Show View -> Project Explorer 
 +  * In the Project tree, right-click on the build folder and choose Properties 
 +  * Check '​Exclude resource from build',​ Apply and Close 
 +  * Repeat for the cache folder  
 + 
 +For Scons builds: 
   * File -> New -> Makefile Project with Existing Code.   * File -> New -> Makefile Project with Existing Code.
   * Set Project Name to ''​mixxx''​.   * Set Project Name to ''​mixxx''​.
Line 99: Line 107:
   * Select Toolchain for indexer setting = ''​Linux GCC''​ (this would be for a Linux host, substitute your OS as applicable).   * Select Toolchain for indexer setting = ''​Linux GCC''​ (this would be for a Linux host, substitute your OS as applicable).
   * Finish.   * Finish.
-  * Right click on the new project in Project Explorer -> Properties -> C/C++ Build (if Project Explorer is not visible, go to Window -> Show View -> Project Explorer).+  * Right click on the new project in Project Explorer -> Properties -> C/C++ Build 
   * Uncheck "Use default build command"​.   * Uncheck "Use default build command"​.
   * Build command ​   * Build command ​
Line 129: Line 137:
   * Uncheck "Use global providers ..."   * Uncheck "Use global providers ..."
   * Edit the command to <​code>​${COMMAND} ${FLAGS} -std=c++11 -E -P -v -dD "​${INPUTS}"</​code> ​   * Edit the command to <​code>​${COMMAND} ${FLAGS} -std=c++11 -E -P -v -dD "​${INPUTS}"</​code> ​
-  * Close Properties +  * Note: The indexer should work after a full rebuild that allows Eclipse to parse all compiler arguments. 
-  * In the Project ​treeright-click on the build folder and choose ​Properties + 
-  * Check '​Exclude resource from build',​ Apply and Close + 
-  * Repeat for the cache folder ​ +For CMake Builds (experimental)  
 + 
 +  * Install cmake4eclipse via the Eclipse Marketplace  
 +    * Help -> Eclipse Marketplace... 
 +    * search for cmake4eclipse and press Install.  
 +    * Follow the install Wizzard and restart Eclipse 
 +  * File -> New -> Project... -> C++ Project  
 +  * Set Project Name to ''​mixxx''​ 
 +  * Uncheck "Use default location"​ 
 +  * Browse to your Mixxx source folder e.g. ''​~/​eclipse-workspace/​mixxx''​. 
 +  * Project Type: Executable -> Empty Project 
 +  * Toolchains: Linux GCC (this would be for a Linux hostsubstitute your OS as applicable). 
 +  * click Finish  
 +  * Right click on the new project in Project Explorer ​-> Properties -> C/C++ Build -> Tool Chain Editor (if Project Explorer is not visible, go to Window -> Show View -> Project Explorer). 
 +  * Curent builder: "CMake Builder (portable)"​ 
 +  * Right click on the new project in Project Explorer -> Properties ​-> C/C++ Build 
 +  * Switch to Behavior tab. 
 +  * Check "​Enable parallel builds"​. 
 +  * Right click on the new project in Project Explorer -> Properties -> C/C++ General -> Preprocessor Include ...  
 +  * Switch to Providers tab 
 +  * check "​CMAKE_COMPILE_COMMANDS_JSON Parser"​ and "​CMAKE_COMPILE_COMMANDS_JSON Compiler Built-Ins"​ and uncheck others
  
 Now Mixxx should build within Eclipse with "Build Project"​ (Hammer icon). ​ Now Mixxx should build within Eclipse with "Build Project"​ (Hammer icon). ​
-The indexer should work after a full rebuild that allows Eclipse to parse all compiler arguments. 
   * Right click on the new project in Project Explorer -> Clean Project   * Right click on the new project in Project Explorer -> Clean Project
   * Right click on the new project in Project Explorer -> Build Project   * Right click on the new project in Project Explorer -> Build Project
eclipse.txt · Last modified: 2020/01/14 17:26 by daschuer